Introduction
This lab lays the foundation of learning CCNA Collaboration. It introduces the basic concepts in the Voice over IP (VoIP) world, and integrates a Cisco Packet Tracer lab for hands-on practice. The combination of theory, methodology and practice helps fast track learning. All the labs on AuTrunk have been developed in such approach.
Figure 1 demonstrates the lab topology. Communications Manager Express (CME) service will be configured on the Cisco 2811 router. Cisco 2950 switch will function as Layer 2 switch. Cisco 7960 IP phones are used to demonstrate phone registration on the CME and retrieve phone number configuration. Phone extension numbers will be 1001, 1002 and 1003.
Figure 1: Packet Tracer IP Telephony Lab
Lab Setup
The lab uses Cisco Packet Tracer (PT) 7.0 to simulate device and environment, which can be downloaded from Cisco Packet Tracer 7.0 from https://www.itechtics.com/download-cisco-packer-tracer-7-0-free-direct-download-links/. If you don’t have Cisco Networking Academy account, start Packet Tracer with Guest login.
Use copper straight through cables for all connections, i.e. between router and switch; between switch and phone. What’s the difference between cross-over cable and straight-through cable? It’s a good opportunity to google if you cannot recall the difference.
IP phone normally has two Ethernet ports (RJ45) at the back as shown in Figure 2. The port marked as SW (or LAN) shall be connected to Switch or a wall port connected to patch panel and eventually switch. The other port marked as PC shall be connected to a computer.
Figure 2: Cisco 7960 Rear View
In Packet Tracer, we will connect the Ethernet cable to the switch port on the phone (Figure 3).
Figure 3: Switch Port and PC Port on Packet Tracer Phone
Many IP Phones these days support Power over Ethernet (PoE), which means the phone can be boot up by Switch power via Ethernet cable , instead of using a power adapter. Since the lab simulator Packet Tracer doesn’t support PoE, we still need to connect the phone to a Power Adapter. You can power up the PT phone by clicking into the phone device, and dragging the power adapter to the phone, as shown in Figure 4. The status indicator on the the Ethernet cable connected to the phone will turn GREEN, upon successfully powering up the phone (Figure 4).
Figure 4: Boot up an IP Phones in Packet Tracer (PT)
Configuration
The configuration steps are summarised as below:
- Configure Interface IPs and DHCP pool on 2811 Router
- Configure Communications Manager Express telephony services on 2811 Router
- Configure Voice VLAN on 2950 Switch
- Verification
Step 1 – Configure Interface IPs and DHCP pool on 2811 Router
Configure FastEthernet 0/0 on 2811 Router, which is connected to the 2950 switch.
Router>enable
Router#configure terminal
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.0
#hard configure duplex in case half-duplex is negotiated. Half-duplex will cause packet drop and degrade voice quality.
Router(config-if)#duplex full
Router(config-if)#no shutdown
Configure DHCP server on the router. The DHCP pool will be 192.168.10.0/24, excluding the router’s IP 192.168.10.1.
#DHCP pool exclude the router (gateway) IP. This helps avoid dynamic IP and static IP conflict.
Router(config)#ip dhcp excluded-address 192.168.10.1
#configure a DHCP pool called VOICE-POOL. IP phone will get dynamic IP, gateway IP (default-router) and DHCP Option 150 attribute from the pool.
Router(config)#ip dhcp pool VOICE-POOL
#DHCP dynamic IP range 192.168.10.0/24
Router(dhcp-config)#network 192.168.10.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.10.1
#Cisco use DHCP Option 150 to provide TFTP server IP address. TFTP server provisions phone configuration to each IP phone, so that we don’t have to log on each phone and manually configure them. In our case, 2811 router is our TFTP server.
Router(dhcp-config)#option 150 ip 192.168.10.1
Step 2 – Configure Communications Manager Express telephony services on 2811 Router
We now configure the Communications Manager Express (CME) telephony service on the 2811 Router. IP phones will register on the CME later.
#configure telephony service,i.e. CME
Router(config)#telephony-service
#limit the maximum number of IP phones can register on this CME. ephone stands for Ethernet phone.
Router(config-telephony)#max-ephones 5
#limit the maximum number of directory numbers. 1 DN = 1 extension number.
Router(config-telephony)#max-dn 5 #Define the maximum number of directory numbers#
#identify the IP address and port number for IP phone registration. TPC 2000 is the default port.
Router(config-telephony)#ip source-address 192.168.10.1 port 2000
#Automatically assigning ext numbers to phone line buttons
Router(config-telephony)#auto assign 1 to 5
We now configure the phone extension numbers. Although the lab only shows 3 phones, we prepare for 5 for future scalability.
#each IP phone profile will have 1 extension number in our case.
Router(config)#ephone-dn 1
Router(config-ephone-dn)#number 1001
Router(config)#ephone-dn 2
Router(config-ephone-dn)#number 1002
Router(config)#ephone-dn 3
Router(config-ephone-dn)#number 1003
Router(config)#ephone-dn 4
Router(config-ephone-dn)#number 1004
Router(config)#ephone-dn 5
Router(config-ephone-dn)#number 1005
If you check the phone status now, it will show “Configuring VLAN” (Figure 5), because the voice VLAN is not configured yet – we will do in the next step.
Figure 5: IP Phone shows “Configuring VLAN” due to voice VLAN not configured
Step 3 – Configure Voice VLAN on 2950 Switch
We configure the 2950 switch ports fa0/1-5 to use VLAN 1 to carry both data and voice traffic. Since VLAN 1 is the default VLAN for data traffic, we just need to configure “switchport voice vlan 1” to use vlan 1 as voice vlan as well. Those are lab configuration only. In production, the following practice is highly recommended:
- Do NOT use default VLAN; and
- Separate data VLAN and voice VLAN, as an example “switchport access vlan 10” for data, and “switchport voice vlan 11” for voice.
Switch(config)#interface range fa0/1 – 5 #Configure interface range#
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport voice vlan 1
The following command demonstrates the interface VLAN status in terms of access VLAN and voice VLAN:
Switch>show interfaces f0/1 switchPort
Name: Fa0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: 1
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
The phones should successfully register to the CME on the 2811 router by now. You will see the following messages on the 2811 router.
%IPPHONE-6-REGISTER: ephone-3 IP:192.168.10.3 Socket:2 DeviceType:Phone has registered.
%IPPHONE-6-REGISTER: ephone-1 IP:192.168.10.2 Socket:2 DeviceType:Phone has registered.
%IPPHONE-6-REGISTER: ephone-2 IP:192.168.10.4 Socket:2 DeviceType:Phone has registered.
Step 5 – Verification
Verify DHCP lease on 2811 router
Router#show ip dhcp binding
IP address Client-ID/ Lease expiration Type
Hardware address
192.168.10.2 0090.2BD1.4A09 — Automatic
192.168.10.3 0001.4215.A32A — Automatic
192.168.10.4 00E0.B079.25EA — Automatic
Verify phone registration on 2811 router
Router# show ephone
ephone-1 Mac:0090.2BD1.4A09 TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:192.168.10.2 1030 7960 keepalive 43 max_line 2
button 1: dn 1 number 1001 CH1 IDLE
ephone-2 Mac:00E0.B079.25EA TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:192.168.10.4 1027 7960 keepalive 43 max_line 2
button 1: dn 2 number 1002 CH1 IDLE
ephone-3 Mac:0001.4215.A32A TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:192.168.10.3 1026 7960 keepalive 43 max_line 2
button 1: dn 3 number 1003 CH1 IDLE
Above shows the IP phones (ephone) use SCCP protocol to register on the CME. Each phone receives an extension number and associated with phone line button 1. SCCP stands for Skinny Call Control Protocol. SCCP is a Cisco proprietary protocol which is used for communication between Cisco Call Manager and Cisco VOIP phones. IP phones from other vendors use Session Initiation Protocol (SIP) for call control. Cisco telephony devices also support SIP for compatibility.
Double click a phone in Packet Tracer, you should see the extension number allocated to the phone (Figure 6).
Figure 6: Phone receives extension number
Figure 7 demonstrates an ephone-dn 3 with extension number 1003 being created and then assigned to the ephone 3, automatic assignment in our case as we configured “auto assign 1 to 5”. The extension number (ephone-dn) is associated with Button 1 of the IP Phone. Therefore, Button 1 is associated with the extension number 1003.
Figure 7: ephone profile configuration and provision process
Reference
Cisco VoIP Implementations, 2008, http://www.ciscopress.com/articles/article.asp?p=1182471&seqNum=2
More: